phhsnews.com


phhsnews.com / Comment regarder Hulu sur Ubuntu et d'autres distributions Linux

Comment regarder Hulu sur Ubuntu et d'autres distributions Linux


Hulu ne fonctionne pas immédiatement sur les distributions Linux modernes. Alors que Netflix "fonctionne" si vous utilisez Google Chrome, le DRM de Hulu est devenu vieux et maladroit. Vous pouvez faire fonctionner Hulu sur Linux, mais ça va prendre un peu de temps.

Ce n'était pas toujours si difficile. À l'époque où Netflix rendait la vie difficile aux utilisateurs de Linux, Hulu offrait même une application de bureau Linux. Mais cette application de bureau est maintenant abandonnée. Hulu s'appuie sur Adobe Flash, et le code DRM d'Adobe Flash est en train de s'effondrer sous Linux.

Vous devrez utiliser Firefox

RELATED: Utiliser Firefox sous Linux? Votre lecteur Flash est vieux et obsolète!

Voici le problème: Hulu s'appuie sur le vieux code Adobe Flash DRM qui nécessite une bibliothèque Linux appelée HAL. Cependant, ce vieux logiciel HAL est assez obsolète et n'a pas été installé par défaut sur les distributions Linux modernes depuis des années. Vous devrez installer des paquets de compatibilité qui permettront à ce DRM basé sur HAL de fonctionner.

Vous devrez également utiliser Mozilla Firefox pour regarder Hulu. L'ancien DRM basé sur HAL ne fonctionne que dans l'ancienne version du plug-in Linux Flash proposé par Firefox. Le nouveau Flash Player basé sur PPAPI (Pepper API) inclus dans Google Chrome ne fonctionnera pas avec l'ancien code DRM de Hulu.

Oui, cela signifie que vous devrez regarder Netflix dans Google Chrome et Hulu dans Mozilla Firefox. La vie n'est-elle pas grandiose?

Première étape: Installer Flash pour Firefox

Vous devez d'abord installer le plug-in Flash Player pour Firefox. Si vous n'avez pas encore installé Flash, un message indique que Hulu a besoin que Flash soit installé lorsque vous essayez de le regarder.

Vous pouvez généralement installer Flash à partir des dépôts de logiciels de votre distribution Linux. Par exemple, sur Ubuntu, ouvrez le Centre logiciel Ubuntu et recherchez "flash". Installez le logiciel "Adobe Flash plug-in".

Assurez-vous d'installer le plugin Flash conçu "pour Mozilla", "pour Firefox" ou la version "NPAPI" du plug-in. La version "PPAPI" ou "pour Chromium" de Flash ne fonctionnera qu'avec les navigateurs Chrome et Chromium.

Deuxième étape: Installation de l'ancienne bibliothèque HAL

Une fois que vous avez installé Firefox et le plug-in Flash pour Firefox , vous pouvez vous diriger vers le site Web de Hulu et essayer de jouer une vidéo. Cependant, vous verrez probablement un message d'erreur lorsque vous le faites. Le message d'erreur indique "Un problème est survenu lors de la lecture de ce contenu protégé. (Code d'erreur: 2203) ". Hulu vous demandera de vous assurer que le paquet HAL est installé, efface votre cache flash et réinitialise les fichiers de licence.

Hulu vous relie à une page Adobe qui vous recommande d'installer le paquet nommé "hal", mais ce paquet n'est plus présente pour l'installation sur les versions modernes d'Ubuntu et d'autres distributions Linux modernes.

Plutôt que d'installer une version du paquet complet HAL - du "zombie HAL PPA" comme on le connaît dans les cercles Ubuntu - nous vous dirigerons vers Une solution plus légère

Martin Wimpress, chef de projet pour Ubuntu MATE, fournit un PPA "hal-flash" qui fournit tout ce dont vous avez besoin pour lire du contenu Flash protégé par DRM sans installer la couche HAL entière. ce logiciel, vous devrez ajouter ce PPA à votre système Ubuntu (cela devrait également fonctionner sur Linux Mint et d'autres distributions dérivées d'Ubuntu). Ouvrez un terminal à partir du tableau de bord et collez ou tapez les commandes suivantes dans l'ordre, en appuyant sur Entrée après chaque. La première commande ajoute le PPA, la seconde télécharge les informations sur les paquets, et la troisième installe la bibliothèque HAL.

sudo add-apt-repository ppa: flexiondotorg / hal-flash

sudo apt-get update
sudo apt-get install libhal1-flash
Si vous utilisez une autre distribution Linux, c'est-à-dire autre chose qu'Ubuntu, Linux Mint ou quelque chose dérivé d'Ubuntu, vous devrez rechercher un paquet HAL pour Flash fourni pour votre distribution Linux. Il peut faire partie des dépôts de paquetages de votre distribution Linux, ou il peut être dans un dépôt tiers comme pour Ubuntu.

Une fois installé, visitez Hulu dans Firefox, réessayez de lire une vidéo, et cela devrait maintenant fonctionner au lieu de vous montrer un message d'erreur "contenu protégé".

Si vous continuez à voir un message d'erreur, vous devrez peut-être fermer Firefox et le redémarrer. Si cela ne fonctionne pas, essayez de redémarrer complètement votre ordinateur avant de continuer.

Cela pose problème depuis de nombreuses années. La page Adobe dit que HAL doit être installé sur les versions 10.x et supérieures d'Ubuntu - cela fait référence aux versions d'Ubuntu publiées en 2010.


Adobe ne veut plus développer Flash sous Linux. La vraie solution ici ne viendra pas quand Adobe corrige son DRM Flash. Au lieu de cela, Hulu doit passer à la lecture vidéo HTML5 moderne, comme Netflix l'utilise dans Google Chrome. Jusqu'à ce qu'ils le fassent, la lecture de Linux sera un peu compliquée.


Comment utiliser le gestionnaire de fichiers intégré d'Android 6.0

Comment utiliser le gestionnaire de fichiers intégré d'Android 6.0

Android inclut un accès complet à un système de fichiers, avec prise en charge des cartes SD amovibles. Mais Android lui-même n'est jamais venu avec un gestionnaire de fichiers intégré, ce qui oblige les fabricants à créer leurs propres applications de gestion de fichiers et les utilisateurs à installer ceux de tiers.

(how-to)

Pourquoi certains iMessages apparaissent-ils comme un e-mail au lieu d'un numéro de téléphone?

Pourquoi certains iMessages apparaissent-ils comme un e-mail au lieu d'un numéro de téléphone?

Avez-vous déjà envoyé des textos à quelqu'un sur votre iPhone? ? Vous êtes là, en tapant joyeusement, quand tout d'un coup vous devez sauter dans une nouvelle boîte de message qui indique que c'est de leur email au lieu du contact principal. Ce bogue mineur dans le système de communication entre iOS et OSX se produira soit si vous avez mal enregistré un contact dans votre téléphone, ou si vous n'avez pas changé leur compte "@me" dans iChat sur leur téléphone sans avoir d'abord éteint l'ancien.

(how-to)